06:59:46 <tahvo> #startmeeting MeeGo QA Weekly 2011-May-10
06:59:46 <MeeGoMeetBot> Meeting started Tue May 10 06:59:46 2011 UTC.  The chair is tahvo. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:59:46 <MeeGoMeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:00:08 <tahvo> #topic Opening and general news
07:00:33 <tahvo> I do not have anything special.
07:00:45 <jessica3> tahvo, i just add one agenda
07:00:49 <iekku> timoph has created new bof
07:00:57 <timoph> yeah.
07:01:00 <jessica3> can i ask in here firstly?
07:01:11 <timoph> http://sf2011.meego.com/program/sessions/bof-meego-qa
07:01:23 <timoph> I'm more than willing to add someone from intel to the presenters
07:01:30 <Stskeeps> there should be an indication that the BoF was accepted during today, as well
07:01:30 <tahvo> timoph: could you post this link with info-tag at the beginning.
07:01:48 <tahvo> jessica3: After this bof.
07:01:52 <timoph> #info proposed QA BoF to the conference
07:01:55 <iekku> Stskeeps, noticed that is's in the accepted list :)
07:01:57 <timoph> #link http://sf2011.meego.com/program/sessions/bof-meego-qa
07:02:04 <iekku> it's even
07:02:13 <tahvo> timoph: thanks
07:02:20 <jessica3> ok, thanks tahvo
07:02:30 <iekku> #info QA BoF is accepted
07:02:30 <Stskeeps> if you have any interesting sessions to present and you're coming to the conference, please submit talks/sessions/bofs
07:02:31 <timoph> iekku: you're saying that it's already accepted?
07:03:15 <iekku> timoph, see what Stskeeps said and yes, it's on the accepted sessions list :D
07:04:02 <timoph> #info the BoF session is already accepted
07:04:12 <timoph> cool
07:04:16 <jessica3> :) good
07:04:29 <timoph> anyone from intel want his/her name added to the presenters?
07:05:42 <jessica3> timoph, can we  later send to you name list ?
07:05:50 <timoph> you can
07:05:52 <jessica3> maybe
07:05:54 <jessica3> sure, thanks
07:06:14 <tahvo> timoph, jessica3: Great.
07:06:17 <tahvo> And keep on proposing sessions, talks and bof like Stskeeps already said.
07:06:20 <iekku> nice
07:06:23 <timoph> but there's only space to add 5 presenters in total. so space for 3 more
07:07:07 <timoph> but it's a bof so the presenters listed there don't have a big difference anyway
07:07:18 <tahvo> Now forward.
07:07:23 <timoph> it just shows that there's a wider interest in the subject
07:07:26 <timoph> ok
07:07:37 <tahvo> jessica3: your turn. You want to ask something.
07:07:44 <jessica3> thanks tahvo
07:07:58 <jessica3> i want to get license file doc for http://testdata.meego.com/
07:08:12 <jessica3> this website has more media contents
07:08:20 <jessica3> which use in mcts-mwts test suite
07:08:53 <jessica3> but once we log in. only can see all contents, no license locate on that? any one can get interface for this?
07:09:32 <tahvo> Tools guys and girls - Any idea who knows and could help on this?
07:09:46 * timoph tries to remember who maintains those
07:10:15 <timoph> vilvo would know but he left the project so..
07:10:23 <timoph> I can find out
07:10:31 <zotte> I have the name somewhere...wait a sec
07:11:03 <zotte> Nico Adahl
07:11:09 <timoph> that's it
07:11:17 <jessica3> Nico adahl
07:11:23 <timoph> yep
07:11:40 <jessica3> can i know some for this interface?
07:11:55 <tahvo> Could you send out NIC and or email to jessica3?
07:12:30 <zotte> here's email: ext-nico.h.adahl@nokia.com
07:12:55 <jessica3> very great , thanks!
07:12:57 <zotte> if I have understand correctly alle the media data there is open sourced
07:13:01 <ville_t> not sure if I understood the question but all files at testdata.meego.com should be public domain
07:13:32 <timoph> but doesn't hurt to show the license info on that page
07:13:38 <ville_t> true
07:13:41 <zotte> ok
07:13:43 <jessica3> yes, i also think like that, but may be still  need one formal doc locate on that website
07:14:13 <jessica3> ok, thanks all !  i get quckly help from here
07:14:18 <jessica3> great place :-)
07:14:34 <tahvo> jessica3: Did we actually got through and completed your agenda item here?
07:15:25 <tahvo> So to next topic then ... Or is there still something?
07:15:26 <jessica3> yes,  done , thanks
07:16:03 <tahvo> #topic Actions from previous meetings (2011-05-03)
07:16:23 <tahvo> #info 1. tahvo to propose Timo Härkonen and Jing Wang as QA tools leads for next TSG meeting. Proposal done - TSG waiting for all nominations.
07:16:40 <tahvo> #info still not completed. I need  to contact Dawn again.
07:16:52 <tahvo> keeping this still until it can be closed.
07:17:18 <tahvo> #action tahvo to propose Timo Härkonen and Jing Wang as QA tools leads for next TSG meeting. Proposal done - TSG waiting for all nominations.
07:17:31 <tahvo> #info 2. yann_a, chris_c, tahvo: Browse through mcts test asset and check if test types are "correct"
07:17:58 <tahvo> I suppose this is done by yann and chris --- I was not fast enough to make any studies.
07:18:14 <timoph> there was some email about it
07:18:24 <tahvo> #info 2. can be closed. See http://lists.meego.com/pipermail/meego-qa/2011-May/001552.html
07:18:46 <yann_a> yes, we made a proposal last week but got no feedback on it
07:19:14 <timoph> that usually means that noone disagrees with it
07:19:16 <tahvo> Maybe now it is time to really make some agreement.
07:19:41 <yann_a> so, if everybody agree, next step will be to fill bugs to get right action
07:19:47 <timoph> yes
07:20:17 <tahvo> I support posting bugs.
07:20:41 <yann_a> and no disagreement regarding proposal?
07:21:30 <tahvo> yann_a: you mean that what test type to be used for "replacement" - do you?
07:21:46 <yann_a> yes
07:23:13 <tahvo> #agreed One can file bugs against test packages/test files if test type is not according the types in http://wiki.meego.com/Quality/Test_areas_and_types
07:23:36 <yann_a> Great, thanks
07:23:51 <tahvo> yann_a: The type which will be used can be discussed through bugs. Right?
07:24:06 <yann_a> yes
07:24:46 <yann_a> but we need to see if there is an overal agreement
07:25:32 <zotte> as a summary of this test-type decisions does it mean that we need to go almost 3000 test cases (2300 core and 700 handset) through and change their test type?
07:25:44 <yann_a> because we don't want to spend our energy filling bugs and tracking them if there is alerady an overall disgrament on our proposal
07:26:27 <tahvo> I suppose the test case itself defines where it shall go.
07:26:38 <yann_a> I think that we must be consistent and follow all the same direction
07:26:59 <yann_a> tahvo: yes
07:27:46 <yann_a> it is not redoing test cases but be sure that they are blonging to the right "test type"
07:27:55 <zotte> yep, test case defines what type it is but if we want to get them right to testplans.meego.com all test cases need to go through and define the correct type
07:28:06 <tahvo> The aim is to have test type according the agreement done earlier. The discussion towards that should happen in bugzilla.
07:28:49 <rajala_rst> Is there any tool or automatic way of doing that. Manually this would be awful task..
07:30:23 <tahvo> Lets file a bugs and see how it starts to progress. Somewhat consensus on this?
07:30:39 <yann_a> I agree that this is a task that may take some time but current vertical situations show that they are diverging from each other and from the definition
07:30:57 <timoph> one could write a script to do the heavy lifting
07:30:58 <yann_a> I am fine with this consensus
07:31:49 <zotte> at least from handset side it needs to be done manually from TestLink (you need human to decide case by case the type)
07:31:56 <timoph> ah
07:32:15 <tahvo> I will make agenda item for next week where we can check the status.
07:32:29 <cris_c> Note also that testlink will need to be updated to support new test types
07:32:44 <tahvo> Okay? Time to go to next topic?
07:33:21 <tahvo> Or actually one more action to go through ...
07:33:43 <tahvo> #info 3 tahvo Include "test packaging for tests coming with components" as a topic for next meeting.
07:34:17 <tahvo> #info 3 is done and can be closed.
07:35:33 <tahvo> #topic Unify "test type" name on qa-reports.meego.com
07:36:46 <tahvo> #info Already gone through with Action 2. Agreed that one can file bugs against test packages/test xmls.
07:37:01 <tahvo> Do someone add something here?
07:37:47 <timoph> nope. reports should show the correct types after they're changed in the xmls
07:37:57 <tahvo> Good - forward then.
07:38:49 <tahvo> #topic http://testdata.meego.com need upload license file and confirm with license.
07:39:30 <tahvo> #info topic covered already on Opening and general news.
07:39:58 <tahvo> Do someone want to add more comments now?
07:40:41 <tahvo> #topic Discussion/approach for usage of test packages from components
07:41:13 <tahvo> This was shortly discussed last time. And it was about reusing the asset included in components/projects already.
07:41:47 <timoph> yep. most test packages that I've tried haven't worked with test automation
07:42:20 <tahvo> So what could be good approach for us? Having tests.xml to document our usage for us? Or something else?
07:42:24 <timoph> the quick and dirty fix is to write a tests.xml of our own
07:42:48 <timoph> but if the actual tests change then there's problems
07:43:16 <tahvo> I suppose this having our own tests.xml might be only solution for the cases where component is used in all distros out there.
07:43:25 <timoph> in the sort term we're going to use mcts test cases with automation
07:43:43 <timoph> and do our own xmls for some selected components
07:43:52 <timoph> after that
07:44:09 <timoph> dunno about other teams doing testing
07:44:17 <timakima> i've done testruns with mcts tests and there aren't many packages working with test automation currently
07:44:35 <timakima> mostly missing tests.xml:s, i guess
07:45:03 <timoph> yep. the problem is that we're tools devs and don't really know what tests are even supposed to work with automation
07:45:28 <tahvo> Qa-leads - any suggestions about the situation?
07:45:44 <timoph> someone needs to give us a list of packages that should work with automation
07:46:20 <yann_a> I think there is a meeting in 13min regating qa tools
07:46:24 <jarnoteivas> we have seen same issue that some of the tests are not working on automation and we are looking for those
07:46:24 <timoph> yep
07:46:29 <yann_a> this question can be raised directly during this meeting
07:46:42 <timoph> let's do that
07:46:47 <rajala_rst> Not suggestions but more concerns mcts working with Meego 1.2 vs 1.3?
07:47:05 <rajala_rst> does it bring any issues ?
07:47:17 <timoph> was mcts branched?
07:47:33 <rajala_rst> that's the queston i think?
07:47:35 <timoph> IMO there should be separate branches for 1.2 and 1.3 in mcts
07:47:40 <jarnoteivas> no, I asked the isseu via email from xzheng
07:48:00 <jarnoteivas> and he said that it is good idea and he will think about it
07:48:08 <timoph> ok
07:48:45 <tahvo> Do we need action here? And what that shall be?
07:48:51 <jarnoteivas> but my opinion is that it have to be branched
07:49:43 <yann_a> jarnoteivas: I also agree
07:49:44 <jarnoteivas> if its not branched we cant test 1.2 images in the future when testassets are updated on 1.3 APIs
07:50:24 <tahvo> Question one: Shall we have test suites branched with the release? Answer: Yes.
07:50:39 <tahvo> Correct?
07:50:42 <jarnoteivas> y
07:50:46 <yann_a> yes
07:51:15 <iekku> :nod:
07:51:23 <rajala_rst> yep
07:51:24 <jarnoteivas> branch mcts 1.2 before API changes on test assets
07:52:08 <tahvo> And if we are branching then I suppose we need to make a "release" out from that and make sure that tests are working.
07:52:13 <tahvo> Correct?
07:52:20 <jarnoteivas> yes, again :)
07:52:44 <yann_a> agree also, this is really common sense
07:53:14 <tahvo> So in order to do that for 1.2 I suppose we need to file bugs for the tests not working. And have our own xml-files if need to be.
07:53:17 <tahvo> Correct?
07:53:46 <jarnoteivas> yes
07:54:31 <yann_a> yes but the xml must be committed also with current maintainer
07:55:05 <tahvo> yann_a: correct. Is this a problem?
07:55:26 <yann_a> no this is not a problem, this is only to be sure this is done :)
07:56:25 <tahvo> Who is making sure that branching is going to happen?
07:56:55 <tahvo> BTW - only two minutes left. I will post 1.2 QA situation to meego-qa list.
07:57:07 <IonutGavaz> same here,on SDK
07:57:52 <tahvo> We need to stop here.
07:58:11 <tahvo> #endmeeting