06:59:30 <tahvo> #startmeeting MeeGo QA Weekly 2011-May-31
06:59:30 <MeeGoMeetBot> Meeting started Tue May 31 06:59:30 2011 UTC.  The chair is tahvo. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:59:30 <MeeGoMeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
06:59:33 <iekku> hi
06:59:35 <cris_c> morning
06:59:57 <tahvo> #topic Opening and general news
07:00:43 <tahvo> So what was best qa take-away from SF Meego Conf?
07:01:17 <timoph> #info minutes from the SF conference QA BoF: http://lists.meego.com/pipermail/meego-qa/2011-May/001678.html
07:02:05 <tahvo> I noticed that there we many issues over there. Shall we reserve time for next meeting for going through this in details?
07:02:18 <timoph> I think we should
07:02:19 <jarnoteivas> + qa dasboard presentation from Leonidas
07:02:47 <FanZhao> I read those minutes and I agree that we could do something to improve :)
07:02:52 <timoph> would help if we could discuss the issues on the mailing list before the meeting
07:03:13 <zotte> yep, discussion easier with mailing list than in IRC
07:03:15 <elvafu> tahvo, i second this
07:04:04 <tahvo> Let's all give comments to thread in meego-qa and take this as item next week.
07:04:34 <zotte> there are already couple of comments given...so, keep comments coming :)
07:04:59 <tahvo> Anything else from SF? Or something else you want to raise here.
07:06:09 <andre__> just for the records, there's also an EM BoF log I've sent to meego-qa@. Please feel free to also comment on anything. :)
07:06:45 <FanZhao> And I noticed Shuang sent out a bugzilla BOF minutes to meego-qa too
07:07:01 <timoph> Was fun to meeting other QA people
07:07:27 <zotte> that's true. nice to get faces for IRC nicks :)
07:07:31 <jarnoteivas> yeah definately worth of discuss f2f
07:07:45 <tahvo> So there were three BoF sessions: QA, EM and Bugzilla. And lots of quality fun with people ;-)
07:07:54 <jarnoteivas> :
07:07:57 <jarnoteivas> :) yeah
07:08:03 <timoph> EM BoF minutes: http://lists.meego.com/pipermail/meego-qa/2011-May/001673.html
07:08:27 <tahvo> #info EM BoF minutes: http://lists.meego.com/pipermail/meego-qa/2011-May/001673.html
07:09:05 <tahvo> Let's move forward --- time flies.
07:09:25 <tahvo> #topic Actions from previous meetings (2011-05-17)
07:09:47 <tahvo> #info 1. tahvo to propose Timo Härkonen and Jing Wang as QA tools leads for next TSG meeting. Proposal done - TSG waiting for all nominations.
07:10:20 <tahvo> #info Now after release is made I need to do second push for this. Still not closed.
07:10:36 <tahvo> #action tahvo to propose Timo Härkonen and Jing Wang as QA tools leads for next TSG meeting. Proposal done - TSG waiting for all nominations.
07:11:02 <tahvo> #info 2. rajala_rst to try to get the feature verification prosess updated in the wikipage according to agreed practise.
07:11:44 <tahvo> rajala_rst: comment?
07:11:50 <rajala_rst> Ongoing..need to find responsible person for 1.3..
07:12:14 <rajala_rst> May be challenging though..
07:12:24 <tahvo> But can this be on for all or is there going to be one per vertical?
07:13:11 <tahvo> So where this practice is today?
07:13:19 <rajala_rst> We need to find someone who can update PM wiki for this..
07:13:28 <zotte> at least currently there is named product manager per UX
07:13:38 <elvafu> agree with rajala_rst, we need find the right to do that
07:14:08 <zotte> still process should be similar in every area
07:14:08 <FanZhao> Maybe I could take the action to contact with PM to get that wiki updated...
07:14:37 <tahvo> So this action to be closed and new one to be created ?
07:15:18 <FanZhao> yes, tahvo, pls. assign a new action to me to contact with PM to get the feature lifecycle wiki updated to reflect reality
07:15:33 <tahvo> #info 2. action closed.
07:15:57 <tahvo> #action FanZhao to contact with PM to get the feature lifecycle wiki updated to reflect reality.
07:16:35 <tahvo> #info 3. iekku to organize triage for the QA-Tools open bugs after SF
07:16:48 <iekku> not done yet
07:17:24 <tahvo> Keeping this active/open ... okay?
07:17:25 <timoph> iekku: let's set a time/date for it today?
07:17:37 <iekku> timoph, agree
07:17:47 <iekku> tahvo, yes
07:18:08 <tahvo> #action iekku to organize triage for the QA-Tools open bugs after SF
07:18:43 <tahvo> That was about the actions.
07:19:08 <tahvo> #topic Follow-up: Creating "release" for tests working with release 1.2
07:19:55 <tahvo> This was done and communicated in meego-qa - was it?
07:20:30 <tahvo> http://build.meego.com/project/show?project=devel:quality:mcts1.2
07:20:32 <elvafu> for mcts release, it is discussed in mail list
07:21:11 <tahvo> were we planning to do it other areas too? Or are we happy now?
07:21:28 <elvafu> personally i like the idea :-)
07:21:54 <elvafu> I have no much idea if other area needs do that too
07:22:44 <tahvo> Dear friends: Comments/opinions?
07:23:45 <tahvo> Maybe we do more with 1.3? I can live with the current situation for 1.2.
07:23:57 * timoph nods
07:24:00 <jarnoteivas> at least I am happy with that mwts stuff
07:24:12 <FanZhao> I think the most critical part is core test, for 1.2, if mcts has reached the target, we are good.
07:24:58 <jarnoteivas> I mean mcts :)
07:25:12 <zotte> mhux has been drifting a while...so not currently touching us
07:25:29 <tahvo> Good. And well done mcts folks.
07:25:43 <tahvo> #topic Follow-up: Unify "test type" name on qa-reports.meego.com
07:26:28 <elvafu> seems none object renaming test type with test set in qa-reports page :-)
07:27:04 <elvafu> how about we talk more about jarno's proposal?
07:27:21 <elvafu> also the test set list that I proposed?
07:28:09 <timoph> got a link to the mail at hand?
07:28:20 <tahvo> #info http://lists.meego.com/pipermail/meego-qa/2011-May/001634.html
07:28:25 <timoph> thanks
07:29:10 <FanZhao> elvafu: I second your proposal
07:29:28 <timoph> for me the issue seems to be mainly about renaming some labels
07:29:30 <FanZhao> It conforms to test set guideline documented at QA wiki
07:30:04 <elvafu> timoph, yes, and at the same time, we propose to finalize the test set list
07:30:05 <tahvo> Jarno's suggestions about the different things/namings in qa-reporst looks fine.
07:30:15 <timoph> yep
07:30:23 <elvafu> I agree with Jarno's suggestion.
07:30:23 <timoph> I don't see any problems with it
07:30:59 <jakeskik_> ok, we rename terms in qa-reports and documentation accordingly
07:31:09 <elvafu> so how about we finalize the test set list too so people can choose it from list?
07:31:56 <timoph> hmmh. I'm not sure I understood the meaning of test set list in this context
07:32:31 <elvafu> timoph, if you going through the page, you will find there are so many test set used
07:32:33 <jakeskik_> elvafu: if Someone(tm) could create a mapping from current test set names to the new names, we can run data migrations to rename the test sets accordingly
07:33:09 <elvafu> jakeskik_, that's okay for me. I only want to make the page clean :-)
07:33:27 <tahvo> timoph: It is the grouping for test sets ... which then define the labels visible/used for qa-reports.
07:33:35 <timoph> ah
07:33:48 <timoph> so it's also about visualization
07:33:53 <jakeskik_> renaming via qa-reports ui would be a bit painful atm as one move only one test report at the time
07:34:09 <tahvo> timoph: has impact on that too ;-)
07:34:48 <jakeskik_> elvafu: I totally agree and would love to see cleaner main page :)
07:34:49 <elvafu> sorry, I have no much idea about how the UI created. so it means it is difficult to implement?
07:35:30 <jakeskik_> elvafu: we can do the renaiming easily as long as someone provides us the mapping
07:35:44 <tahvo> I would suggest that jakeskik_ can implement - and elvafu helps by providing the naming for test sets.
07:35:53 <timoph> but yeah. I also think those test types/sets should have more unified naming
07:36:00 <elvafu> tahvo, thanks
07:36:18 <elvafu> I will talk with jakeskik_ directly, thanks again
07:36:20 <jakeskik_> tahvo: sounds good
07:36:39 <elvafu> so we can move to next topic I think :-)
07:36:45 <timoph> yep
07:37:26 <tahvo> is action needed here or are we clear?
07:37:55 <zotte> elvafu, when making mapping proposal please provide that to qa-mailing list also => others can comment
07:38:07 <timoph> btw, please have the discussion in the open at least for the essential parts
07:38:07 <elvafu> tahvo, you can add an action for jakeskik and me ;-)
07:38:12 <elvafu> zotte, sure
07:38:27 <zotte> elvafu, thanks
07:38:34 <jakeskik> tahvo: action #1 elva to send test set renaming proposal to mailing list
07:38:52 <tahvo> #agreed jakeskik can implement the changes in qa-reporst - and elvafu helps by providing the naming for test sets.
07:39:10 <elvafu> thanks Jakeskik, tahvo
07:39:18 <jakeskik> tahvo: thanks
07:39:55 <tahvo> elvafu: one comment round still with the naming in meego-qa.
07:40:15 <elvafu> tahvo, which one?
07:40:24 <elvafu> could you give me a link? thanks
07:41:23 <tahvo> summarizing the things done ... or was this the thing that was asked by zotte?
07:42:20 <zotte> yep, when doing the mapping proposal please share that to qa-mailing list
07:42:32 <elvafu> yeah
07:42:52 <elvafu> no problem
07:43:19 <tahvo> Okay. forward.
07:43:42 <tahvo> #topic Review: Test set instead test type to be used in qa-reports
07:44:01 <tahvo> We already covered this on previous topic. Anything to add?
07:44:22 <FanZhao> no from me
07:44:39 <elvafu> no
07:44:49 <tahvo> okay ... forward.
07:45:04 <tahvo> #topic Review: Updates/additional chapters to Component Test Plan Template
07:45:15 <elvafu> the update is done
07:45:50 <elvafu> and thanks for comments from jari
07:45:54 <elvafu> :-)
07:46:05 <tahvo> Do anyone has something to add here? I'm happy with the changes.
07:46:31 <FanZhao> Good updates, nothing to be added from my perspective
07:46:59 <FanZhao> Maybe we could move on as we still have a few topics :)
07:47:02 <tahvo> #info http://wiki.meego.com/CompTestPlanTemplate is updated.
07:47:38 * timoph fixed one type in it
07:47:42 <timoph> typo even
07:47:46 <timoph> vision -> version
07:47:59 <elvafu> timoph, thanks
07:48:22 <timoph> np
07:48:41 <tahvo> FanZhao: about the rest of topics ... did you want to combine 1.3 QA Plan with testability review topic?
07:48:54 <FanZhao> Yes, tahvo, that's my intention
07:49:35 <tahvo> So maybe 1st this proposal for new members and then 1.3 test planning.
07:49:47 <FanZhao> ok
07:50:11 <tahvo> #topic Proposal: adding Yanshuang Zheng and Jie Zhou in error manager team of meego.com
07:50:56 <andre__> in short: "Why?" :)
07:51:17 <iekku> +1
07:51:31 <FanZhao> in short: "additional people to help resolved issues in bug lifecycle"
07:51:49 <andre__> is that also doable outside of EM? what are exactly the advantages of being in EM to push for that?
07:52:00 <andre__> as I wrote on the wiki: The bigger a team, the harder to make decisions
07:52:07 <andre__> that's one reason why I'm reluctant.
07:52:29 <FanZhao> I think people could focus on different areas, as we are having more and more bugs to be followed up
07:52:49 <andre__> also, is Jie Zhou = jiex.a.zhou@intel in Bugzilla and on mailing lists?
07:53:14 <elvafu> agree. there are only 4 people in EM team. personally I don't think add two more is a big problem, who can help on different area. :-)
07:53:29 <FanZhao> Positioning as error manager would make it easier for them to communicate with people
07:53:48 <andre__> what hinders them currently to communicate?
07:53:54 <elvafu> andre_, yes
07:54:05 <andre__> elvafu, ah, okay.
07:54:10 <andre__> I see exactly 21 bug reports with activity of jiex.a.zhou. Not much, and not convinced that this is sufficient. I see zero postings on meego-qa@ mailing list by jiex.a.zhou.
07:54:11 <andre__> If I have no idea who some people are I try to find some traces by them in the project. And if I don't find anything I am very reluctant plus afraid that some understanding of working in the open might be missing.
07:54:20 <FanZhao> aruravi_: he is new to MeeGo
07:54:26 <FanZhao> just as you from half an year ago :)
07:54:33 <elvafu> adnre_ i mean Jie Zhou = jiex.a.zhou@intel in Bugzilla
07:54:42 <FanZhao> But he will dedicate more time in bug management area moving forward
07:54:49 <iekku> elvafu, did you have certain areas on your mind? and what about the responsibilities of the QA contact?
07:54:50 <andre__> actually it's a bit longer than half a year, plus you can find out about me in GNOME Bugzilla e.g. :)
07:55:01 <andre__> If he's new, please keep in mind that MeeGo's governance model is based on meritocracy and the best practices and values of the Open Source culture.
07:55:07 <FanZhao> andre__: good to know :)
07:55:19 <andre__> I can't judge on meritocracy if there's no visible activity whatsoever.
07:55:24 <elvafu> iekku, I told andre_ that who is zhoujie. I have no idea why you said that
07:55:39 <tahvo> andre___, iekku, FanZhao, elvafu: shall we leave this open now and you try to find a consensus during the week?
07:55:50 <timoph> let's keep it open
07:55:55 <andre__> Communication is less than perfect in EM anyway (I'm missing transparency from both some Nokia and Intel folks on what people work on, also see the latest thread on meego-qa@). I don't think that improves by adding more people.
07:55:57 <andre__> yes, open.
07:55:59 <iekku> elvafu, oh sorry, that was for FanZhao
07:56:04 <elvafu> agree with timoph, let's be open :-)
07:56:16 <FanZhao> well, let's keep that open at the moment
07:56:19 <timoph> at least I don't see us getting anywhere close to an agreement on this
07:56:22 <iekku> agree
07:56:27 <tahvo> #agreed to leave this topic to be discussed more ...
07:56:55 <FanZhao> Let's revisit it next week then...
07:56:59 <tahvo> We run out of time so shall we start 1.3 test planning discussion on meego-qa?
07:57:04 <FanZhao> yes
07:57:05 <andre__> I won't vote "yes" as long as I don't feel like knowing some of the proposed folks **at all**.
07:57:14 <jarnoteivas> yes we should start it
07:57:23 <FanZhao> only one minute left for that
07:57:41 <jarnoteivas> on next week
07:57:45 <FanZhao> #topic 1.3 planning
07:57:54 <jarnoteivas> and start it on emails
07:58:11 <iekku> FanZhao, can't add topic if you aren't chair
07:58:17 <tahvo> #topic Sharing/Discussion: 1.3 QA plan and feature testability review
07:58:20 <FanZhao> iekku: ok
07:58:27 <timoph> time's up
07:58:30 <tahvo> #agreed - discussion to be started in meego-qa.
07:58:40 <tahvo> #endmeeting