11:01:16 <msugano> #startmeeting MeeGo CE, 30 August 2011
11:01:16 <MeeGoMeetBot> Meeting started Tue Aug 30 11:01:16 2011 UTC.  The chair is msugano. Information about MeetBot at http://wiki.debian.org/MeetBot.
11:01:16 <MeeGoMeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
11:01:25 <msugano> #topic Action Followup
11:01:32 <msugano> #info jukkaeklund to RFC on the CE governance.
11:01:41 <msugano> jukkaeklund: any update on this?
11:02:49 <msugano> will remind jukkaeklund when he comes back.
11:02:54 <lcuk> msugano, on Friday this was brought up and i have spent the last few days discussing this and steering/roadmapping elements
11:03:12 <lcuk> and concensus seems to be towards a 1.4 roadmap
11:03:28 <lcuk> making use of the best we can gather http://wiki.meego.com/Roadmap1.4
11:03:48 <jukkaeklund> stskeeps could update on the governance?
11:04:18 <Stskeeps> lcuk's been looking a bit and talking with people, he's still writing up things and i'm waiting for some proposals from him on how steering could be operated
11:04:48 <Stskeeps> so there should hopefully be additional discussion over next week and a factual proposal for next meeting
11:05:01 <msugano> ok, so http://wiki.meego.com/Roadmap1.4 is the forum where the info is centralized.
11:05:15 <msugano> #link http://wiki.meego.com/Roadmap1.4 related to the open governance.
11:05:26 <msugano> good start.
11:05:32 <lcuk> yes msugano
11:05:42 <lcuk> and discussion will continue as Stskeeps says
11:05:43 <msugano> #info msugano to inform the code camp setup to the stakeholders.
11:05:53 <msugano> lcuk: ok
11:05:57 <lcuk> been reading a lot about the yocto project and their governance
11:06:33 <jukkaeklund> though I dont think calling it 1.4 gives the right idea
11:06:49 <msugano> #link http://www.yoctoproject.org/ can we learn from the yocto project?
11:07:03 <Stskeeps> :nod: i think we should perhaps place it underneath the CE namespace and "Directions" or something
11:07:17 <jukkaeklund> yes
11:07:21 <lcuk> jukkaeklund, it was just the version put around for the larger changes people seem to be steering towards
11:07:44 * lcuk new at this so learning
11:07:51 <jukkaeklund> then 2.0 would better..
11:07:54 <dm8tbr> probably CE should have ow roadmap aligned with proposed 1.4 roadmap
11:08:43 <msugano> ok, but we all agree that we want the CE-2.0 anyway..
11:08:48 <lcuk> jukkaeklund, my original aim was to document the feasible deliverables for each version
11:08:53 <lcuk> yes msugano
11:09:28 <msugano> direction seems right, let us continue the discussion on the names and the contents..
11:09:36 <lcuk> ++
11:09:44 <msugano> then for the above action, sorry I haven't done yet.
11:09:57 <msugano> it will be 3 days before the integration deadline.
11:10:03 <msugano> will do during this week.
11:10:19 <msugano> #action msugano to inform the code camp setup to the stakeholders.
11:10:27 <msugano> #info msugano to host the App team monday meeting 29 August 2011.
11:10:30 <jukkaeklund> and F2F should be 28th sep in tampere
11:10:48 <msugano> that's mindtrek, correct?
11:11:01 <jukkaeklund> just before openmind party
11:11:19 <msugano> ok
11:11:31 <jukkaeklund> mind trek starts next day
11:11:40 <msugano> as for the app meeting, it's done.
11:11:41 <msugano> #link http://irclogs.meego.com/meetbot/meego-meeting/2011/meego-meeting.2011-08-29-08.01.html CE App meeting minutes.
11:11:44 <msugano> jukkaeklund: ok
11:12:04 <msugano> #topic New HW support
11:12:14 <msugano> #info The remaining items 1, releasing moslo (source & binary).
11:12:21 <msugano> #info The remaining items 2, uploading the instructions.
11:12:29 <msugano> #info The remaining items 3, N950 official software update.
11:12:48 <Stskeeps> we're still waiting for 3) as far as i know?
11:12:56 <msugano> Stskeeps: yes.
11:13:02 <dm8tbr> msugano: instructions seem fairly complete already
11:13:09 <msugano> 3) is out of our hands.
11:13:14 <msugano> dm8tbr: good to know.
11:13:42 <msugano> #topic CE App support
11:13:54 <msugano> vesku is off this week, so i will be updating the status.
11:13:58 <msugano> #info mkainu is working on the IRC chat app.
11:14:04 <msugano> #info vnayani is working on Dialer.
11:14:08 <msugano> #info jpal is working on TwimGo crash.
11:14:15 <msugano> guys, feel free to fill me in.
11:14:26 <vnayani> Yes , I have been following the oin querry bug
11:14:58 <msugano> ok, thanks vnayani
11:15:02 <vnayani> THere is no issue in ofono or dialer
11:15:17 <msugano> so that's that.
11:15:27 <msugano> #chair jukkaeklund
11:15:27 <MeeGoMeetBot> Current chairs: jukkaeklund msugano
11:15:32 <vnayani> Looks like some issue with UI
11:15:34 <msugano> jukkaeklund: whatever you have
11:15:42 <vnayani> Any how i am still investigating this
11:16:05 <jukkaeklund> on mobile, nothing to add..
11:16:14 <msugano> :)
11:16:22 <jukkaeklund> any questions?
11:16:39 <msugano> i thought your fingers could do more than this..
11:17:04 <msugano> #chair Stskeeps
11:17:04 <MeeGoMeetBot> Current chairs: Stskeeps jukkaeklund msugano
11:17:07 <lcuk> the push from quim gil towards geting harmattan app running in -ce is good
11:17:07 <jukkaeklund> lacking irc client..
11:17:25 <lcuk> jukkaeklund, an irc client for harmattan is being devolped in part by venemo
11:17:34 <lcuk> he has good history of cross compatible qt stuff
11:17:34 <Stskeeps> i can do a quick adaptation update
11:17:46 <jukkaeklund> updating Qt and qml is question?
11:17:48 <lcuk> and with guidance and showing its possible following miniature I think he will try
11:17:52 <lcuk> yes
11:17:57 <Stskeeps> kimju has pushed 3.0.0 based kernel to git which is great
11:17:59 <lcuk> we need latest qt components and qt quick
11:18:02 <msugano> #topic Adaptation Update
11:18:16 <Stskeeps> #info kimju has pushed 3.0.0 based kernel to git which is great
11:18:27 * msugano thanks
11:18:49 <dm8tbr> \o/
11:18:59 <Stskeeps> i've worked on teesting MTF on top of 1.3 a bit today, which had interesting results (qt 4.8):
11:19:19 <Stskeeps> #link http://stskeeps.subnetmask.net/meego/20110830_001.jpg widgets gallery (home worked too, but there is a problem with theme daemon)
11:19:29 <Stskeeps> #link http://a34.video2.blip.tv/12480009237603/Stskeeps-QtComponentsHarmattanOnN900MeeGo13based313.m4v?brs=1529&bri=2.1
11:19:36 <jukkaeklund> timos plasma looks cool
11:19:37 <Stskeeps> Qt components on top of qt4.8 seems to perform really well
11:19:57 <Stskeeps> (sorry for odd file format)
11:21:05 <Stskeeps> and various other activities such a n950 phone microphone reversal, build optimizations for ARM, camera UI and pulseaudio merging
11:21:09 <jukkaeklund> works in N9 :)
11:21:23 <Stskeeps> the usual boring technical stuff ;)
11:21:37 <jukkaeklund> if it didnt work well would be a surprise..
11:21:58 <Stskeeps> i'll be working with Sage tomorrow to produce MTF UI images for the mtf guys to help out with/debug
11:22:17 <msugano> ok
11:22:22 <Stskeeps> and i think that's it from me
11:22:54 <msugano> the qt component demo in the video, very nice.
11:22:58 <Sage> jukkaeklund: is there a link to the timos plasma?
11:23:04 <msugano> ok thanks Stskeeps
11:23:14 <msugano> #topic AOB
11:23:29 <msugano> is there anything you would like to share?
11:23:40 <msugano> I see harha is here.
11:23:45 <msugano> how are you?
11:23:51 <Stskeeps> #link timoph.blogspot.com/2011/08/running-plasma-active-desktop-on-top-of.html
11:23:54 <Stskeeps> err
11:23:58 <Stskeeps> #link http://timoph.blogspot.com/2011/08/running-plasma-active-desktop-on-top-of.html
11:24:07 <harha> Quite okay, thank you ;)
11:24:34 <msugano> hope you are getting better.
11:25:02 <harha> Yes, I am.
11:25:39 <msugano> when are you taking off the iron bolt?
11:25:42 <jukkaeklund> think about usage of plasma UI i  CE
11:26:03 <harha> Still almost 2 weeks before I am allowed to walk without stiks..
11:26:23 <harha> That bolt will be there for the rst of my life ..
11:26:42 <msugano> oh
11:26:48 <harha> ..
11:27:13 <msugano> if it doesn't kill, makes you stronger..
11:27:23 <harha> I hope so ..
11:28:10 <msugano> ok, we should all contribute to this CE-2.0 discussion. Let's have a look at the wiki.
11:28:12 <Stskeeps> one thing that i do wonder about - if we have a 1.3 based UI that's more compatible to harmattan, would that be better as our september release?
11:28:20 <Stskeeps> because of qt4.8 etc
11:28:39 <msugano> Stskeeps: what is the other option?
11:28:42 <kallam> iron bolt is not very nice in airports
11:28:45 <Sage> My question is that will CE-2.0 naming be a bit confusing?
11:28:58 <Stskeeps> msugano: implementing new qt and so on, perhaps 1.3 based UI is only way..
11:29:05 <dm8tbr> I'd suggest to go along with MeeGo naming
11:29:18 <Sage> Maybe we should include the meego version to the name or something instead.
11:29:18 <harha> kallam: probably not
11:29:28 <Sage> CE-1.3, CE-1.4 etc.
11:29:46 <msugano> Stskeeps: at least for the Fall release, 1.3 based UI looks reasonable to me.
11:29:49 <dm8tbr> Sage: like MeeGo 1.2 har^wCE?
11:29:52 <Stskeeps> ok
11:30:08 <harha> Stskeeps: 1.3 still has X ?
11:30:22 <lcuk> yes
11:30:26 <Stskeeps> yes, currently
11:30:31 <Stskeeps> not going away for 1.3
11:30:33 <Sage> dm8tbr: yes but with actual meego core ;)
11:30:40 <Stskeeps> we can probably do wayland experiments but MTF wouldn't work well on top
11:30:43 <lcuk> Sage, I agree, thinking in steps is better than 2.0
11:30:45 <Stskeeps> so for fall, it's safer with xorg
11:30:46 <msugano> Sage: dm8tbr: l am open to any naming. just used CE-2.0 for the convenience.
11:30:56 <dm8tbr> *nod*
11:30:57 <lcuk> since at least until we know how the intel side is going
11:30:58 <Sage> msugano: :nod:
11:31:01 <lcuk> would be best to continue
11:31:13 <msugano> Stskeeps: we can take more aggressive approach from October.
11:31:48 <harha> So is 1.3 (UI) stable for september ?
11:31:49 <Stskeeps> yep
11:31:58 <Stskeeps> harha: i think it could be, it didn't seem very broken when i tried it
11:32:18 <Sage> do we need the UI from 1.3 ?
11:32:40 <Stskeeps> Sage: could you rephrase that?
11:32:40 <msugano> Sage: you mean the tablet UX?
11:32:41 <Sage> we are still using the MTF for 1.3 right? And that is something we have in our own project
11:32:46 <Stskeeps> Sage: right
11:33:16 <Stskeeps> so we can do fast integration and get stuff working :P
11:33:17 <harha> So you want to take core / QT from 1.3 ?
11:33:22 <Stskeeps> harha: right
11:33:36 <harha> Why not ..
11:33:36 <Sage> the tablet ux is currently not compiling for 1.3 so can't say much about that and 1.3
11:33:37 <Stskeeps> as that's closer for harmattan developers
11:33:55 <msugano> Core (1.3) + UI (MTF project)
11:34:00 <Stskeeps> i would advise against any tablet ux stuff currently as the git repositories seem to have stalled completely, at least
11:34:05 <Stskeeps> so i wouldn't spend much time on that
11:34:10 <Stskeeps> (from CE POV)
11:34:24 <dm8tbr> there might be a big reveal coming, or nothing, who knows
11:34:24 <harha> Sounds like wise advise ..
11:34:31 <Sage> Stskeeps: +1 for that
11:34:39 <msugano> dm8tbr: tell us about that :)
11:34:51 <dm8tbr> if only I knew :)
11:34:57 <msugano> :)
11:35:00 <msugano> ok dok smok
11:35:08 <msugano> may be time to close the meeting for today.
11:35:17 <msugano> thank you everybody.
11:35:25 <msugano> see you around.
11:35:28 <Stskeeps> thank you
11:35:33 <msugano> #endmeeting