08:01:31 <veskuh> #startmeeting meego-n900ce-apps-2011-05-09
08:01:31 <MeeGoMeetBot> Meeting started Mon Sep  5 08:01:31 2011 UTC.  The chair is veskuh. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:31 <MeeGoMeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:01:46 <veskuh> Hi all
08:01:50 <Stskeeps> o/
08:02:13 <veskuh> #topic General Info
08:02:45 <veskuh> There is not much to say about this. I've been away so I do not know all that has been happening
08:03:00 <veskuh> but If understand correctly there has been some progress in rebasing to 1.3
08:03:19 <veskuh> good thing about 1.3 would be more up to date Qt
08:03:20 <Stskeeps> yep, did you see the qml components video?
08:03:32 <veskuh> Stskeeps: yes I did. Looked quite smooth
08:04:18 <veskuh> With that we could get rid of some workarounds that were done on our Qt-components
08:04:19 <Stskeeps> i guess our primary focus is harmattan compatibility - kate already said we should upgrade our components version in 1.3
08:04:40 <veskuh> Yes, that would help us get apps
08:04:47 <veskuh> also in future
08:05:48 <veskuh> Ok, let's see where we are
08:06:03 <veskuh> #topic Status (please state what you've been doing the last week related to this project, prefix with #info)
08:06:28 <vnayani> Working on Bug 22279 , Have a fix with me currently , will submit it soon.
08:06:31 <MeeGoBot> Bug https://bugs.meego.com/show_bug.cgi?id=22279 maj, Medium, ---, sirpa.h.kemppainen, NEW, [CE] N950: SIM PIN code query broken
08:06:52 <veskuh> #info vnayani fixing 22279, will have fix soon
08:07:03 <veskuh> vnayani: great. out of curiosity how are you fixing that?
08:07:14 <vnayani> It is a kind of window update issue which isn't working in case of N950. Exact reason is till unclear , But when i tried to use another API then started working fine.
08:07:21 <Sage> vnayani: could you assign that bug to yourself and set state as assinged?
08:07:32 <vnayani> Sage: Ok , Will do that.
08:07:59 <Sage> vnayani: there are some problems with n950 modem support in ofono, might be related to that?
08:08:00 <vnayani> I  have updated the bug report as well on this .
08:08:14 <veskuh> #action vnayani to update bug assignee and status on 22279
08:08:17 <jpal1> #info fixed a couple of remaining WiFi applet releated bugs, one of the fixes still under testing, most likely will post the patch later today. But not much else last week (did not spend time on TwimGo)
08:08:22 <vnayani> No..ofono does not have to do any thing with this issue
08:08:43 <Sage> vnayani: ok
08:08:43 <vnayani> I tried to run the ofono scripts , they worked fine
08:09:15 <veskuh> mkainu_:  how is irc-chat work going?
08:09:16 <vnayani> As i said it is kind of UI update stuff , We see this only in N950.
08:11:02 <mkainu_> veskuh: still some compiling problems with libircclient library, I can send you some mail about it.  Last week made some qt-components test app ..
08:11:51 <veskuh> mkainu_:  ok, good.
08:12:10 <lcuk> mkainu_, have you been liaising with venemo who is making irc client also
08:12:24 <lcuk> he is making it on harmattan and so once we get components it should work
08:12:31 <veskuh> lcuk: that is the same app
08:12:39 <lcuk> :D
08:12:46 <veskuh> mkainu_:  has been trying to get it working on CE
08:12:52 <lcuk> then the answer is yes! :D
08:13:52 <veskuh> Any other updates?
08:14:28 <Stskeeps> does MTF framework belong under this area?
08:14:45 <veskuh> Stskeeps: yes, but Mirek is on vacation this week.
08:14:47 <Stskeeps> ok
08:15:17 <lcuk> veskuh, motivation for polishing apps from community
08:15:26 <lcuk> more a question of how do we do it
08:16:17 <Stskeeps> make guides from moving from harmattan to meego.com packaging for components based stuff?
08:16:39 <lcuk> that would be a good start
08:16:43 <veskuh> Stskeeps: yes, that is a good idea
08:16:46 <lcuk> timoph has been leading by example
08:16:56 <lcuk> we could use qgils miniature as testcase
08:17:15 <lcuk> real world example of in development harmattan app
08:17:24 <veskuh> we should make that as easy as possible.  documentation is one thing.
08:17:55 <Sage> Stskeeps: there is deb2spectacle ;)
08:18:06 <Stskeeps> hehe
08:18:19 <lcuk> sage, really?
08:18:26 <lcuk> does it work well for most cases?
08:18:27 <Sage> lcuk: yes, Haven't tried it
08:19:03 <Sage> lcuk: http://meego.gitorious.org/meego-developer-tools/spectacle/blobs/master/tools/deb2spectacle
08:19:24 <Sage> if that works it should be quite easy to move from .deb to .rpm
08:19:53 <veskuh> #link http://meego.gitorious.org/meego-developer-tools/spectacle/blobs/master/tools/deb2spectacle
08:20:16 <veskuh> #info deb2spectacle may help developers to port apps to ce
08:20:25 <Sage> also not sure if that does what I expect it to do :P
08:20:45 <lcuk> Sage, worth a try though :)
08:20:47 <Sage> yes
08:21:00 <veskuh> anyway, let's move to next topic.
08:21:03 <veskuh> #topic Next steps (please state what you plan to do next for this project, prefix with #info)
08:23:24 <veskuh> #info I'm going to see if jpal1's CSS tips will help fix bug 22636
08:23:27 <MeeGoBot> Bug https://bugs.meego.com/show_bug.cgi?id=22636 maj, Medium, ---, benjamin.t.drucker, NEW, [CE] Conversation view cannot be scrolled properly to view all messages
08:24:01 <jpal1> #info will post that one remaining WiFi applet patch (password dialog changed to a sheet, vkb works better in both orientations), _might_ take a new look at TwimGo
08:24:31 <iekku> #info iekku having other work dutys as well, limited working hours for CE, trying to do the rest in the evenings
08:26:12 <veskuh> mkainu_:  vnayani what are your next steps?
08:26:41 <vnayani> As of now, I will work on completing this pin querry fix.
08:27:07 <veskuh> #info vnayani to complete pin query fix
08:27:08 <vnayani> And i hope we have few more issues after that and i have haptics some back log stuff as well..
08:27:10 <mkainu_> I will try to get that client compiled
08:27:20 <mkainu_> maybe I will cintact to Venemo
08:27:49 <veskuh> mkainu_:  that would be good
08:28:15 <Stskeeps> he's friendly :)
08:28:57 <veskuh> #topic AOB
08:29:10 <veskuh> allright, any other business
08:29:43 <lcuk> what cool apps have people seen this week?  on meego or elsewhere
08:32:15 <veskuh> Haven'n seen new cool apps this week.
08:32:48 <veskuh> I guess it's time to end the meeting and continue chats on other meego channels.
08:32:49 <veskuh> Thanks
08:32:50 <Stskeeps> will there be any objection to dumping tablet UX apps for performance reasons?
08:33:06 <Stskeeps> and concentrating on qt components and what community makes there
08:33:24 <Stskeeps> (tablet ux does not build for 1.3 atm)
08:33:28 <veskuh> Stskeeps: not from me unless we have something really cool on tablet ux.
08:33:43 <veskuh> Stskeeps: and I do not think that tablet ux apps at the momenet are too great.
08:34:10 <Stskeeps> yep - the components (tablet) work seem to have stalled
08:34:40 <veskuh> Really? the whole work or integration to meego?
08:34:57 <Stskeeps> completely, go look at the gitorious
08:35:50 <Stskeeps> well, some collabora people still work, but something's more silent than normally :)
08:36:04 <veskuh> Ok, then it makes sense for us to focus on qt components at the moment.
08:36:07 <Stskeeps> yep
08:37:08 <veskuh> #info as meego-ux is not working on 1.3 we are focusing our effort on Qt Components
08:37:15 <veskuh> #endmeeting