07:59:42 <jwang-dest> #startmeeting QA-Tools weekly meeting May 31th 2011
07:59:42 <MeeGoMeetBot> Meeting started Tue May 31 07:59:42 2011 UTC.  The chair is jwang-dest. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:59:42 <MeeGoMeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:09 <jwang-dest> #chair timoph
08:00:09 <MeeGoMeetBot> Current chairs: jwang-dest timoph
08:00:51 <jwang-dest> #topic actions from last meeting
08:01:50 <jwang-dest> * arnoteivas to provide list of mcts test packages that work with OTS
08:02:06 <jwang-dest> * jarnoteivas to provide list of mcts test packages that work with OTS
08:02:36 <timakima> at least i got some list from härkönen
08:02:58 <timakima> i haven't tested all of them yet, though
08:03:06 <jwang-dest> timakima, could you share the list?
08:03:40 <timakima> sure. if jarnoteivas don't have any updates? the list is from 17. may
08:04:53 <jwang-dest> * Shao-Feng follow up on getting QML_ID patch into MeeGo/Qt
08:05:54 <jwang-dest> #info timaima share initial mcts package list, and jarnoteivas may provide update
08:07:03 <jwang-dest> I know some update from shaofeng about it
08:07:55 <jwang-dest> #info Shaofeng contact QT maintainer of MeeGo, but not got feedback yet.  continue ping him
08:08:30 <jwang-dest> * iekku to update mcts wiki page
08:09:08 <jwang-dest> looks iekku not here
08:09:14 <timoph> iekku: ping
08:09:25 <iekku> i'm here
08:09:30 <iekku> haven't done it
08:09:45 <iekku> this is my first work day after conference
08:10:00 <jwang-dest> #action iekku to update mcts wiki page
08:10:00 <iekku> hoping that i can say in next meeting "done"
08:10:00 <timoph> ok. let's keep it open
08:10:06 <timoph> :)
08:10:31 <jwang-dest> #topic latest tool status
08:11:16 <timoph> releases etc from past two weeks from our side are listed here: http://wiki.meego.com/Quality/Meetings/QA_leads_update_1.2#QA-tools_Update
08:11:46 <eluttine> planning to have next OTS release 0.8.6 on week 23. thanks to all who have created bugs and corrections
08:11:59 <timoph> stuff like corelysis open sourcing, new versions of OTS, min and test-definition
08:12:44 <timoph> timakima et al. what's current state of the core analysis thing?
08:13:02 <timakima> we've had successfull runs with the backend
08:13:06 <jwang-dest> #info Nokia side - stuff like corelysis open sourcing, new versions of OTS, min and test-definition, details http://wiki.meego.com/Quality/Meetings/QA_leads_update_1.2#QA-tools_Update
08:13:47 <timakima> we're waiting for the crash reports ui currently
08:14:18 <timoph> so we can upload traces, etc. already?
08:14:32 <timakima> i think we can upload, but not view yet :)
08:14:38 <timoph> ok. cool
08:14:50 <jwang-dest> timakima, who is owner of carelysis?
08:14:56 <timakima> the whole thing needs testing, of course
08:15:04 <timoph> the maintainer?
08:15:08 <jwang-dest> yes
08:15:11 <sampos> \o
08:15:22 <rikhalon> o/
08:15:32 * timakima keeping his hands down
08:15:45 <timoph> so rikhalon and sampos are your men for it
08:16:10 <rikhalon> yes, for now atleast
08:16:15 <jwang-dest> good to know
08:16:26 <jwang-dest> I have a question
08:16:42 <jwang-dest> In tool list, there are 2 items which confuse me
08:17:00 <jwang-dest> "Crash reporter" and "Rich core dumper", do they mean same thing?
08:17:06 <timoph> no
08:17:46 <sampos> crash reporter is UI for uploading traces produced by rich-core-dumper
08:18:14 <timoph> yep. I think we had this discussion in the last meeting iirc
08:18:24 <jwang-dest> In description, "crash reporter" say "On-devive tool for sending core dumps to core dump data base"
08:19:35 <jwang-dest> So, I guess it need a bit polish to make purpose more clear
08:19:48 <jwang-dest> I mean in description
08:19:50 <timoph> it does that and then the core is processed
08:20:01 <timakima> btw, not all tools have any kind of description in gitorious. perhaps the maintainers could update them
08:20:09 <timoph> we are not processing cores in the device itself
08:20:52 <timoph> so the reporter send the cores for analysis into the dump db
08:20:53 <sampos> and we are not using crash reporter in the automated testing
08:20:58 <timoph> yep
08:21:20 <jwang-dest> crash report is actually a manual tool, right?
08:21:33 <timoph> I can also send things automatically
08:21:41 <timoph> but basically yes
08:22:16 <jwang-dest> Ok, in OTS, crash reporter is not used
08:22:25 <timoph> yes
08:22:54 <jwang-dest> it is another path to push crash data into data base
08:23:02 <sampos> exactly
08:23:08 <jwang-dest> thanks for clarication
08:23:11 <timoph> np
08:24:09 <jwang-dest> How about sb update tool list to make sure every tool has a clear description
08:24:35 <timoph> sb?
08:24:47 <jwang-dest> somebody?
08:24:55 <timoph> ah
08:25:00 <jwang-dest> voluteer
08:25:17 <timoph> well I can go through them tomorrow
08:25:26 <iekku> sorry, i need to leave this meeting now
08:25:32 <timoph> iekku: o/
08:25:35 <timakima> i'd urge the maintainers to update them
08:25:57 <jwang-dest> #action timoph go through tool list description
08:26:11 <timoph> iekku: let's talk about the QA tools bug triage later then
08:26:48 <jwang-dest> shaofeng, could you provide update about GUI automation?
08:27:09 <jwang-dest> Shao-Peng, ping
08:27:11 <Shao-Feng> OK
08:27:46 <Shao-Feng> We have prepare some cucumber steps for GUI automation test.
08:28:23 <Shao-Feng> and going to commit them onto gitorious, but for now, I still have some issue to resolve
08:28:27 <timoph> are the somewhere where I can get my hands on them?
08:28:44 <timoph> oh. already answered that :)
08:29:09 <Shao-Feng> I suppose they will be available before tomorrow, ?
08:29:27 <jwang-dest> #info Shaofeng create new repo - MeeGo QML GUI Testlib, will check in initial code soon after
08:30:27 <jwang-dest> Anyone would like update status?
08:30:46 <timakima> Shao-Feng: is that the same as auto-ux-testlib i created today?
08:30:54 <Shao-Feng> Yes
08:31:02 <timakima> ok, no need for a new repo then
08:31:15 <Shao-Feng> 1 update for the QML_ID patch
08:31:25 <jwang-dest> good
08:32:03 <Shao-Feng> I have create and commit an OBS request, but  no response from the maintainer
08:32:04 <timakima> oh, btw. please send requests to new repos for meego-qa list instead of directly via email
08:32:43 <timakima> for example last time timoph was travelling and it took some time he could forward the request to me
08:33:02 <Shao-Feng> Ahh, I suppose an automatical generated email was sent by OBS to meego-commit
08:33:23 <Shao-Feng> Ahh, OK sure
08:33:52 <Shao-Feng> BTW, Thanks a lot to bothTimo :-)
08:34:14 <Shao-Feng> Back to the QML_ID patch,
08:34:51 <Shao-Feng> I ever send mail to ask Jenny (maintainer ) to review twice, but still no response
08:35:16 <Shao-Feng> and I am done
08:36:00 <jwang-dest> #info Shaofeng sent mail to ask Jenny (maintainer ) to review QML_ID patch twice, but still no response
08:36:26 <Shao-Feng> Could someone help to push this thread?
08:36:33 <Shao-Feng> maybe from Nokia?
08:36:41 <jwang-dest> Shao-Feng, let's find a way to escalate this issue
08:37:31 <jwang-dest> I am wondering Nokia side can help push QML_ID pathc into QT upstream. It block tdriver testing on QML application
08:37:47 <timoph> dunno
08:38:27 <timoph> but it won't get there fast anyway so we need in meego as a patch anyway first
08:38:34 <timakima> i don't know qt development process enough to say anything. they don't have public mailing lists for patches/requests?
08:38:46 <timoph> timakima: they do
08:39:03 <jwang-dest> there is merge request in QT upstream, but keep NEW for very long time
08:39:12 <timoph> but I'm not that familiar with those
08:39:46 <jwang-dest> Keep it open, let's push it from both upstream and meego path
08:39:51 <timoph> yep
08:40:20 <jwang-dest> #action Shao-feng continue to push QML_ID patch into MeeGo
08:40:54 <jwang-dest> #topic Any other business?
08:41:59 <jwang-dest> 3
08:42:06 <jwang-dest> 2
08:42:21 <jwang-dest> 1
08:42:34 <jwang-dest> done?
08:42:39 <timoph> I think so
08:42:45 <jwang-dest> #endmeeting